NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🎯
🎯 Pub
Not in CISA KEV
HIGH severity

CVE-2024-29887 — serverpod_client

HIGHFix: serverpod/serverpod@d55bf8d

CVE-2024-29887 is a high-severity (CVSS 7.4) CWE-295 vulnerability in serverpod_client. A fix is available for serverpod_client — see the affected versions and patch details below.

Serverpod client accepts any certificate

Also known asGHSA-h6x7-r5rg-x5fw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29887.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.26%0.52%0.78%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🎯serverpod_client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Pub packages — download data is not available via public APIs for these ecosystems.

Description

Serverpod is an app and web server, built for the Flutter and Dart ecosystem. This bug bypassed the validation of TSL certificates on all none web HTTP clients in the serverpod_client package. Making them susceptible to a man in the middle attack against encrypted traffic between the client device and the server. An attacker would need to be able to intercept the traffic and highjack the connection to the server for this vulnerability to be used. Upgrading to version 1.2.6 resolves this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🎯Pubserverpod_clientall versions1.2.6dart pub upgrade serverpod_client

Affected Products

1 product · 1 configurations
Application
serverpodserverpod
< 1.2.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for serverpod_client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update serverpod_client to 1.2.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29887 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Serverpod is an app and web server, built for the Flutter and Dart ecosystem. This bug bypassed the validation of TSL certificates on all none web HTTP clients in the `serverpod_client` package. Making them susceptible to a man in the middle attack against encrypted traffic between the client device and the server. An attacker would need to be able to intercept the traffic and highjack the connection to the server for this vulnerability to be used. Upgrading to version `1.2.6` resolves this issue.
O3 Security · Impact-Aware SCA

Is CVE-2024-29887 in your dependencies?

Find it across Pub, including transitive dependencies.

CVE-2024-29887: serverpod_client — Fixed in 1.2.6