NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2024-29651 — @apidevtools/json-schema-…

HIGHFix: APIDevTools/json-schema-ref-parser@8cad7f7

CVE-2024-29651 is a high-severity (CVSS 8.1) CWE-1321 vulnerability in @apidevtools/json-schema-ref-parser. A fix is available for @apidevtools/json-schema-ref-parser — see the affected versions and patch details below.

json-schema-ref-parser Prototype Pollution issue

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-29651.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.20%1.26%2.32%3.38%2.8%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

648other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@apidevtools/json-schema-ref-parsernpm
14.4Mdownloads / week

Description

A Prototype Pollution issue in API Dev Tools json-schema-ref-parser v.11.0.0 and v.11.1.0 allows a remote attacker to execute arbitrary code via the bundle(), parse(), resolve(), dereference() functions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@apidevtools/json-schema-ref-parser≥ 11.0.0&&< 11.2.011.2.0npm install @apidevtools/json-schema-ref-parser@11.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @apidevtools/json-schema-ref-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @apidevtools/json-schema-ref-parser to 11.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-29651 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Developer Hub does not use a vulnerable version of json-schema-ref-parser. Therefore, it is not affected by this vulnerability.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-29651 (CC BY 4.0)

Frequently Asked Questions

A Prototype Pollution issue in API Dev Tools json-schema-ref-parser v.11.0.0 and v.11.1.0 allows a remote attacker to execute arbitrary code via the `bundle()`, `parse()`, `resolve()`, `dereference()` functions.
O3 Security · Impact-Aware SCA

Is CVE-2024-29651 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-29651: RCE — Fixed in 11.2.0