NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2024-28635 — survey-creator

MEDIUM

CVE-2024-28635 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in survey-creator. A fix is available for survey-creator — see the affected versions and patch details below.

Cross-site scripting in Survey Creator

Also known asGHSA-xgj4-2hrf-j4xg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 21, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28635.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.34%0.67%1.01%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
survey-creatornpm
2Kdownloads / week

Description

Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before, allows attackers to execute arbitrary code and obtain sensitive information via the title parameter in form.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsurvey-creatorall versions1.9.133npm install survey-creator@1.9.133

Affected Products

1 product · 1 configurations
Application
survey-creatordevsoftbaltic
≤ 1.9.132
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for survey-creator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update survey-creator to 1.9.133 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28635 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before, allows attackers to execute arbitrary code and obtain sensitive information via the title parameter in form.
O3 Security · Impact-Aware SCA

Is CVE-2024-28635 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-28635: survey-creator RCE — Fixed in 1.9.133