CVE-2024-28109 is a high-severity (CVSS 8.1) CWE-91 vulnerability in org.verapdf:core. A fix is available for org.verapdf:core — see the affected versions and patch details below.
Potential XSLT injection vulnerability when using policy files
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28109.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.verapdf:core☕org.verapdf:core-jakarta☕org.verapdf:core-arlington☕org.verapdf:verapdf-library-arlington☕org.verapdf:verapdf-library☕org.verapdf:verapdf-library-jakarta☕org.verapdf:library-arlington☕org.verapdf:library+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Executing policy checks using custom schematron files invokes an XSL transformation that may theoretically lead to a remote code execution (RCE) vulnerability.
Patches
This has been patched and users should upgrade to veraPDF v1.24.2
Workarounds
This doesn't affect the standard validation and policy checks functionality, veraPDF's common use cases. Most veraPDF users don't insert any custom XSLT code into policy profiles, which are based on Schematron syntax rather than direct XSL transforms. For users who do, only load custom policy files from sources you trust.
References
Original issue: https://github.com/veraPDF/veraPDF-library/issues/1415
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.verapdf:core | all versions | 1.24.2org.verapdf:core:1.24.2 |
| ☕Maven | org.verapdf:core-jakarta | all versions | 1.24.2org.verapdf:core-jakarta:1.24.2 |
| ☕Maven | org.verapdf:core-arlington | all versions | 1.25.127org.verapdf:core-arlington:1.25.127 |
| ☕Maven | org.verapdf:verapdf-library-arlington | all versions | 1.25.127org.verapdf:verapdf-library-arlington:1.25.127 |
| ☕Maven | org.verapdf:verapdf-library | all versions | 1.24.2org.verapdf:verapdf-library:1.24.2 |
| ☕Maven | org.verapdf:verapdf-library-jakarta | all versions | 1.24.2org.verapdf:verapdf-library-jakarta:1.24.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.verapdf:core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.verapdf:core to 1.24.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-28109 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-28109 in your dependencies?
Find it across Maven, including transitive dependencies.