CVE-2024-27439 — wicket
MEDIUMCVE-2024-27439 is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in org.apache.wicket:wicket. A fix is available for org.apache.wicket:wicket — see the affected versions and patch details below.
Apache Wicket: Possible bypass of CSRF protection
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-27439.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.wicket:wicket☕org.apache.wicket:wicketReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
An error in the evaluation of the fetch metadata headers could allow a bypass of the CSRF protection in Apache Wicket. This issue affects Apache Wicket: from 9.1.0 through 9.16.0, and the milestone releases for the 10.0 series. Apache Wicket 8.x does not support CSRF protection via the fetch metadata headers and as such is not affected.
Users are recommended to upgrade to version 9.17.0 or 10.0.0, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.wicket:wicket | ≥ 9.1.0&&< 9.17.0 | 9.17.0org.apache.wicket:wicket:9.17.0 |
| ☕Maven | org.apache.wicket:wicket | ≥ 10.0.0-M1&&< 10.0.0 | 10.0.0org.apache.wicket:wicket:10.0.0 |
Affected Products
wicketapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.wicket:wicket, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.wicket:wicket to 9.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-27439 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-27439 in your dependencies?
Find it across Maven, including transitive dependencies.