CVE-2024-27317 — pulsar-functions-worker
HIGHCVE-2024-27317 is a high-severity (CVSS 8.4) Path Traversal vulnerability in org.apache.pulsar:pulsar-functions-worker. EPSS puts its 30-day exploitation probability at 56.9% (99th percentile). A fix is available for org.apache.pulsar:pulsar-functions-worker — see the affected versions and patch details below.
Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-27317.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.pulsar:pulsar-functions-worker☕org.apache.pulsar:pulsar-functions-worker☕org.apache.pulsar:pulsar-functions-worker☕org.apache.pulsar:pulsar-functions-worker☕org.apache.pulsar:pulsar-functions-workerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Pulsar Functions Worker, authenticated users can upload functions in jar or nar files. These files, essentially zip files, are extracted by the Functions Worker. However, if a malicious file is uploaded, it could exploit a directory traversal vulnerability. This occurs when the filenames in the zip files, which aren't properly validated, contain special elements like "..", altering the directory path. This could allow an attacker to create or modify files outside of the designated extraction directory, potentially influencing system behavior. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true".
This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0.
2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.pulsar:pulsar-functions-worker | ≥ 2.4.0&&< 2.10.6 | 2.10.6org.apache.pulsar:pulsar-functions-worker:2.10.6 |
| ☕Maven | org.apache.pulsar:pulsar-functions-worker | ≥ 2.11.0&&< 2.11.4 | 2.11.4org.apache.pulsar:pulsar-functions-worker:2.11.4 |
| ☕Maven | org.apache.pulsar:pulsar-functions-worker | ≥ 3.0.0&&< 3.0.3 | 3.0.3org.apache.pulsar:pulsar-functions-worker:3.0.3 |
| ☕Maven | org.apache.pulsar:pulsar-functions-worker | ≥ 3.1.0&&< 3.1.3 | 3.1.3org.apache.pulsar:pulsar-functions-worker:3.1.3 |
| ☕Maven | org.apache.pulsar:pulsar-functions-worker | ≥ 3.2.0&&< 3.2.1 | 3.2.1org.apache.pulsar:pulsar-functions-worker:3.2.1 |
Affected Products
pulsarapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pulsar:pulsar-functions-worker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.pulsar:pulsar-functions-worker to 2.10.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-27317 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Apache Pulsar is not part of EAP - it's not present in the EAP dependency tree and not distributed in the product maven repository. EAP is not affected.
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-27317 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-27317 in your dependencies?
Find it across Maven, including transitive dependencies.