NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-27292 — docassemble-webapp

HIGHFix: jhpyle/docassemble@97f77dc

CVE-2024-27292 is a high-severity (CVSS 7.5) CWE-706 vulnerability in docassemble-webapp. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for docassemble-webapp — see the affected versions and patch details below.

Docassemble unauthorized access through URL manipulation

Also known asGHSA-jq57-3w7p-vwvvPYSEC-2026-1309PYSEC-2026-2453
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
3 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-27292.

EPSS Exploitation Probability

via FIRST.org ↗
69.5%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
62.2%74.8%87.4%100.0%93.8%69.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍docassemble-webapp🐍docassemble-base

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96.

Patches

The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched.

Workarounds

If upgrading is not possible, manually apply the changes of 97f77dc and restart the server.

Credit

The vulnerability was discovered by Riyush Ghimire (@richighimi).

For more information

If you have any questions or comments about this advisory:

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdocassemble-webapp≥ 1.4.53&&< 1.4.971.4.97pip install --upgrade 'docassemble-webapp==1.4.97'
🐍PyPIdocassemble-base≥ 1.4.53&&< 1.4.971.4.97pip install --upgrade 'docassemble-base==1.4.97'

Affected Products

1 product · 1 configurations
Application
docassemblejhpyle
≥ 1.4.53 && < 1.4.97
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for docassemble-webapp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update docassemble-webapp to 1.4.97 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-27292 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2024-27292

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-27292 -u https://target
Template
Docassemble - Local File Inclusion
Severity
high
Impact
Unauthenticated attackers can read arbitrary files on the server through URL manipulation in the Docassemble interview endpoint.
Remediation
Update Docassemble to version 1.4.97 or later.

Template by ProjectDiscovery nuclei-templates (johnk3r), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. ### Patches The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched. ### Workarounds If upgrading is not possible, manually apply the changes of [97f77dc](https://github.com/jhpyle/docassemble/commit/97f77dc486a26a22ba804765bfd7058aabd600c9) and restart the server. ### Credit The vulnerability was discovered by Riyush Ghimire (@richighimi). ### For more inform
O3 Security · Impact-Aware SCA

Is CVE-2024-27292 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-27292: docassemble-webapp — Fixed in 1.4.97