NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-26164 — mssql-django

HIGH

CVE-2024-26164 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in mssql-django. A fix is available for mssql-django — see the affected versions and patch details below.

Remote Code Execution Vulnerability in Microsoft Django Backend for SQL Server

Also known asPYSEC-2026-1684
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-26164.

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.86%3.08%5.30%7.51%6.3%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mssql-django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Microsoft Django Backend for SQL Server Remote Code Execution Vulnerability

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImssql-djangoall versions1.4.1pip install --upgrade 'mssql-django==1.4.1'

Affected Products

1 product · 1 configurations
Application
django backendmicrosoft
< 1.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mssql-django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mssql-django to 1.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-26164 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Microsoft Django Backend for SQL Server Remote Code Execution Vulnerability
O3 Security · Impact-Aware SCA

Is CVE-2024-26164 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-26164: mssql-django RCE — Fixed in 1.4.1