NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2024-24768 — 1Panel

MEDIUMFix: 1Panel-dev/1Panel@1169648

CVE-2024-24768 is a medium-severity (CVSS 6.5) CWE-315 vulnerability in github.com/1Panel-dev/1Panel. A fix is available for github.com/1Panel-dev/1Panel — see the affected versions and patch details below.

1Panel set-cookie is missing the Secure keyword

Also known asGHSA-9xfw-jjq2-7v8hGO-2024-2531
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24768.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs23th percentile — riskier than 23% of all scored CVEsHighest risk
0.00%0.27%0.54%0.80%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/1Panel-dev/1Panel

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

The https cookie that comes with the panel does not have the Secure keyword, which may cause the cookie to be sent in plain text when accessing http accidentally.

https://developer.mozilla.org/zh-CN/docs/Web/HTTP/Headers/Set-Cookie#secure

PoC

Directly configure https for the panel, and then capture the packet when logging in again and find that the cookie does not have the Secure keyword

Impact

Everyone who has configured the panel https

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/1Panel-dev/1Panelall versions1.9.6go get github.com/1Panel-dev/1Panel@v1.9.6

Affected Products

1 product · 1 configurations
Application
1panelfit2cloud
1 version
1.9.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/1Panel-dev/1Panel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/1Panel-dev/1Panel to 1.9.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24768 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary The https cookie that comes with the panel does not have the Secure keyword, which may cause the cookie to be sent in plain text when accessing http accidentally. https://developer.mozilla.org/zh-CN/docs/Web/HTTP/Headers/Set-Cookie#secure ### PoC Directly configure https for the panel, and then capture the packet when logging in again and find that the cookie does not have the Secure keyword ### Impact Everyone who has configured the panel https
O3 Security · Impact-Aware SCA

Is CVE-2024-24768 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-24768: 1Panel — Fixed in 1.9.6