CVE-2024-24558 is a high-severity (CVSS 8.2) Cross-site Scripting (XSS) vulnerability in @tanstack/react-query-next-experimental. A fix is available for @tanstack/react-query-next-experimental — see the affected versions and patch details below.
react-query-streamed-hydration xss
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-24558.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@tanstack/react-query-next-experimentalnpmDescription
Impact
The @tanstack/react-query-next-experimental NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this, an attacker would need to either inject malicious input or arrange to have malicious input be returned from an endpoint.
This vulnerability arises from improper handling of untrusted input when @tanstack/react-query-next-experimental performs server-side rendering of HTML pages. To fix this vulnerability, we implemented appropriate escaping to prevent javascript injection into rendered pages.
Patches
To fix this issue, please update to version 5.18.0 or later.
Workarounds
There are no known workarounds for this issue. Please update to version 5.18.0 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @tanstack/react-query-next-experimental | ≥ 5.0.0&&< 5.18.0 | 5.18.0npm install @tanstack/react-query-next-experimental@5.18.0 |
Affected Products
react-query-next-experimentaltanstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @tanstack/react-query-next-experimental, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @tanstack/react-query-next-experimental to 5.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-24558 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-24558 in your dependencies?
Find it across npm, including transitive dependencies.