CVE-2024-11319 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in django-cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for django-cms — see the affected versions and patch details below.
Stored XSS in Open Source Project "django-cms"
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-11319.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django-cms🐍django-cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in django CMS Association django-cms allows Cross-Site Scripting (XSS).
This issue affects django-cms: 3.11.7, 3.11.8, 4.1.2, 4.1.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django-cms | ≥ 3.11.7&&< 3.11.9 | 3.11.9pip install --upgrade 'django-cms==3.11.9' |
| 🐍PyPI | django-cms | ≥ 4.1.2&&< 4.1.4 | 4.1.4pip install --upgrade 'django-cms==4.1.4' |
Affected Products
django cmsdjango-cmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django-cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django-cms to 3.11.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-11319 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-11319 in your dependencies?
Find it across PyPI, including transitive dependencies.