CVE-2015-5081 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in django-cms. A fix is available for django-cms — see the affected versions and patch details below.
django-cms CSRF Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django-cms🐍django-cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site request forgery (CSRF) vulnerability in django CMS before 3.0.14, 3.1.x before 3.1.1 allows remote attackers to manipulate privileged users into performing unknown actions via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django-cms | all versions | 3.0.14pip install --upgrade 'django-cms==3.0.14' |
| 🐍PyPI | django-cms | ≥ 3.1.0b1&&< 3.1.1 | 3.1.1pip install --upgrade 'django-cms==3.1.1' |
Affected Products
django cmsdjango-cmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django-cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django-cms to 3.0.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5081 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2015-5081 in your dependencies?
Find it across PyPI, including transitive dependencies.