CVE-2024-10940 is a medium-severity (CVSS 5.3) CWE-497 vulnerability in langchain-core. A fix is available for langchain-core — see the affected versions and patch details below.
Exposure of Sensitive System Information via ImagePromptTemplate in langchain-ai/langchain
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-10940.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
langchain-core🐍langchain-core🐍langchain-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability in langchain-core versions >=0.1.17,<0.1.53, >=0.2.0,<0.2.43, and >=0.3.0,<0.3.15 allows unauthorized users to read arbitrary files from the host file system. The issue arises from the ability to create langchain_core.prompts.ImagePromptTemplate's (and by extension langchain_core.prompts.ChatPromptTemplate's) with input variables that can read any user-specified path from the server file system. If the outputs of these prompt templates are exposed to the user, either directly or through downstream model outputs, it can lead to the exposure of sensitive information.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | langchain-core | ≥ 0.1.17&&< 0.1.53 | 0.1.53pip install --upgrade 'langchain-core==0.1.53' |
| 🐍PyPI | langchain-core | ≥ 0.2.0&&< 0.2.43 | 0.2.43pip install --upgrade 'langchain-core==0.2.43' |
| 🐍PyPI | langchain-core | ≥ 0.3.0&&< 0.3.15 | 0.3.15pip install --upgrade 'langchain-core==0.3.15' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langchain-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update langchain-core to 0.1.53 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-10940 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-10940 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-10940 in your dependencies?
Find it across PyPI, including transitive dependencies.