NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2023-6293 — sequelize-typescript

HIGHFix: robinbuschmann/sequelize-typescript@5ce8afd

CVE-2023-6293 is a high-severity (CVSS 7.5) CWE-1321 vulnerability in sequelize-typescript. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for sequelize-typescript — see the affected versions and patch details below.

Prototype Pollution in robinbuschmann/sequelize-typescript

Also known asGHSA-7pvx-4585-hqww
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.73%1.09%0.1%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

855other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
sequelize-typescriptnpm
825Kdownloads / week

Description

Prototype Pollution in GitHub repository robinbuschmann/sequelize-typescript prior to 2.1.6.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsequelize-typescriptall versions2.1.6npm install sequelize-typescript@2.1.6

Affected Products

1 product · 1 configurations
Application
sequelize-typescriptsequelizejs
< 2.1.6
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sequelize-typescript, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sequelize-typescript to 2.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-6293 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Prototype Pollution in GitHub repository robinbuschmann/sequelize-typescript prior to 2.1.6.
O3 Security · Impact-Aware SCA

Is CVE-2023-6293 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-6293: sequelize-typescript — Fixed in 2.1.6