NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-5571 — @vrite/sdk

MEDIUMFix: vriteio/vrite@1877683

CVE-2023-5571 is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in @vrite/sdk. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @vrite/sdk — see the affected versions and patch details below.

Improper Input Validation in vriteio/vrite

Also known asGHSA-44ff-9w4f-99w6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5571.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk+0.11%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.84%1.26%0.0%0.6%0.8%Jun 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@vrite/sdknpm
380downloads / week

Description

Improper Input Validation in GitHub repository vriteio/vrite prior to 0.3.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@vrite/sdkall versions0.3.0npm install @vrite/sdk@0.3.0

Affected Products

1 product · 1 configurations
Application
vritevrite
< 0.3.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @vrite/sdk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @vrite/sdk to 0.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5571 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Improper Input Validation in GitHub repository vriteio/vrite prior to 0.3.0.
O3 Security · Impact-Aware SCA

Is CVE-2023-5571 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-5571: @vrite/sdk — Fixed in 0.3.0