CVE-2023-5245 is a high-severity (CVSS 7.5) Path Traversal vulnerability in ml.combust.mleap:mleap-runtime_2.12. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ml.combust.mleap:mleap-runtime_2.12 — see the affected versions and patch details below.
Using MLeap for loading a saved model (zip archive) can lead to path traversal/arbitrary file creation and possibly remote code execution.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ml.combust.mleap:mleap-runtime_2.12Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
FileUtil.extract() enumerates all zip file entries and extracts each file without validating whether file paths in the archive are outside the intended directory.
When creating an instance of TensorflowModel using the saved_model format and an exported tensorflow model, the apply() function invokes the vulnerable implementation of FileUtil.extract().
Arbitrary file creation can directly lead to code execution
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | ml.combust.mleap:mleap-runtime_2.12 | all versions | 0.23.1ml.combust.mleap:mleap-runtime_2.12:0.23.1 |
Affected Products
mleapcombustResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ml.combust.mleap:mleap-runtime_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ml.combust.mleap:mleap-runtime_2.12 to 0.23.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5245 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2023-5245 in your dependencies?
Find it across Maven, including transitive dependencies.