CVE-2023-51450 is a medium-severity (CVSS 5.6) OS Command Injection vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.
baserCMS OS command injection vulnerability in Installer
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-51450.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
baserproject/basercmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
There is a OS command injection in Installer Feature to baserCMS.
Target
baserCMS 5.0.8 and earlier versions
Vulnerability
Malicious command may be executed in Installer.
Countermeasures
Update to the latest version of baserCMS
Please refer to the following page to reference for more information. https://basercms.net/security/JVN_73283159
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | baserproject/basercms | all versions | 5.0.9composer require baserproject/basercms:^5.0.9 |
Affected Products
basercmsbasercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update baserproject/basercms to 5.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-51450 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2023-51450 in your dependencies?
Find it across Packagist, including transitive dependencies.