CVE-2023-50722 is a critical-severity (CVSS 9.6) Cross-site Scripting (XSS) vulnerability in org.xwiki.platform:xwiki-platform-administration-ui. A fix is available for org.xwiki.platform:xwiki-platform-administration-ui — see the affected versions and patch details below.
XWiki Platform XSS/CSRF Remote Code Execution in XWiki.ConfigurableClass
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-administration-ui☕org.xwiki.platform:xwiki-platform-administration-ui☕org.xwiki.platform:xwiki-platform-administration-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
There is a reflected XSS or also direct remote code execution vulnerability in the code for displaying configurable admin sections. The code that can be passed through a URL parameter is only executed when the user who is visiting the crafted URL has edit right on at least one configuration section. While any user of the wiki could easily create such a section, in this case it is much more convenient to exploit GHSA-qj86-p74r-7wp5 which is why this attack scenario won't be further considered in the following. In contrast to GHSA-qj86-p74r-7wp5, this vulnerability doesn't require the attacker to have an account or any access on the wiki. It is sufficient to trick any admin user of the XWiki installation to visit the crafted URL. Alternatively, the URL can also be embedded as image source of an image in any content of the wiki like a comment that could be left by an anonymous user. This vulnerability allows full remote code execution with programming rights and thus impacts the confidentiality, integrity and availability of the whole XWiki installation.
Patches
This has been fixed in XWiki 14.10.15, 15.5.2 and 15.7RC1
Workarounds
The patch can be manually applied to the document XWiki.ConfigurableClass.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-administration-ui | ≥ 2.3&&< 14.10.15 | 14.10.15org.xwiki.platform:xwiki-platform-administration-ui:14.10.15 |
| ☕Maven | org.xwiki.platform:xwiki-platform-administration-ui | ≥ 15.0-rc-1&&< 15.5.2 | 15.5.2org.xwiki.platform:xwiki-platform-administration-ui:15.5.2 |
| ☕Maven | org.xwiki.platform:xwiki-platform-administration-ui | ≥ 15.6-rc-1&&< 15.7-rc-1 | 15.7-rc-1org.xwiki.platform:xwiki-platform-administration-ui:15.7-rc-1 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-administration-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-administration-ui to 14.10.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-50722 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-50722 in your dependencies?
Find it across Maven, including transitive dependencies.