CVE-2023-29514 is a critical-severity (CVSS 9.9) CWE-74 vulnerability in org.xwiki.platform.applications:xwiki-application-administration. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform.applications:xwiki-application-administration — see the affected versions and patch details below.
Code injection in template provider administration in xwiki-platform
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-29514.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform.applications:xwiki-application-administration☕org.xwiki.platform:xwiki-platform-administration☕org.xwiki.platform:xwiki-platform-administration-ui☕org.xwiki.platform:xwiki-platform-administration-ui☕org.xwiki.platform:xwiki-platform-administration-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Any user with edit rights on any document (e.g., the own user profile) can execute code with programming rights, leading to remote code execution by following these steps:
- Set the title of any document you can edit (can be the user profile) to
{{async async="true" cached="false" context="doc.reference"}}{{groovy}}println("Hello " + "from groovy!"){{/groovy}}{{/async}}
- Use the object editor to add an object of type
XWiki.TemplateProviderClass(named "Template Provider Class") to that document. - Go to another document you can view (can be the home page) and append
?sheet=XWiki.AdminTemplatesSheetto the URL.
When the attack is successful, a template with name "Hello from groovy!" is displayed in the list while on fixed systems, the full title should be displayed.
Patches
This vulnerability has been patched in XWiki 13.10.11, 14.4.8, 14.10.1 and 15.0 RC1.
Workarounds
The vulnerability can be fixed by patching the code in the affected XWiki document as shown in the patch.
References
- https://jira.xwiki.org/browse/XWIKI-20268
- https://github.com/xwiki/xwiki-platform/commit/7bf7094f8ffac095f5d66809af7554c9cc44de09
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform.applications:xwiki-application-administration | ≥ 1.35 | No fix |
| ☕Maven | org.xwiki.platform:xwiki-platform-administration | ≥ 3.1-milestone-1 | No fix |
| ☕Maven | org.xwiki.platform:xwiki-platform-administration-ui | ≥ 4.2-milestone-1&&< 13.10.11 | 13.10.11org.xwiki.platform:xwiki-platform-administration-ui:13.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-administration-ui | ≥ 14.0-rc-1&&< 14.4.8 | 14.4.8org.xwiki.platform:xwiki-platform-administration-ui:14.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-administration-ui | ≥ 14.5&&< 14.10.1 | 14.10.1org.xwiki.platform:xwiki-platform-administration-ui:14.10.1 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform.applications:xwiki-application-administration, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2023-29514; check the affected-versions list above or the advisory for the patched release of org.xwiki.platform.applications:xwiki-application-administration, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-29514 in your dependencies?
Find it across Maven, including transitive dependencies.