NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-50709 — @cubejs-backend/api-gatew…

MEDIUM

CVE-2023-50709 is a medium-severity (CVSS 6.5) Improper Input Validation vulnerability in @cubejs-backend/api-gateway. A fix is available for @cubejs-backend/api-gateway — see the affected versions and patch details below.

Denial of service attack on the cube-api endpoint

Also known asGHSA-9759-3276-g2pm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-50709.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.81%1.22%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

15other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@cubejs-backend/api-gatewaynpm
80Kdownloads / week

Description

Impact

It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint.

Patches

The issue has been patched in the v0.34.34 and it's recommended that all users exposing Cube APIs to the public internet upgrade to the latest version to prevent service disruption.

Workarounds

There are currently no workaround for older versions, and the recommendation is to upgrade.

References

The issue was reported by y0d3n in our Community Slack and has been promptly patched in the recent update.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@cubejs-backend/api-gatewayall versions0.34.34npm install @cubejs-backend/api-gateway@0.34.34

Affected Products

1 product · 1 configurations
Application
cube.jscube
< 0.34.34
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @cubejs-backend/api-gateway, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @cubejs-backend/api-gateway to 0.34.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-50709 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. ### Patches The issue has been patched in the `v0.34.34` and it's recommended that all users exposing Cube APIs to the public internet upgrade to the latest version to prevent service disruption. ### Workarounds There are currently no workaround for older versions, and the recommendation is to upgrade. ### References The issue was reported by [y0d3n](https://github.com/y0d3n) in our Community Slack and has been promptly patched in the recent update.
O3 Security · Impact-Aware SCA

Is CVE-2023-50709 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-50709: @cubejs-backend/api — Fixed in 0.34.34