NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-50550 — layui

MEDIUM

CVE-2023-50550 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in layui. A fix is available for layui — see the affected versions and patch details below.

Layui cross-site scripting (XSS) vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.31%0.61%0.92%0.4%0.3%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

14other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
layuinpm
7Kdownloads / week

Description

layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmlayuiall versions2.7.5npm install layui@2.7.5

Affected Products

1 product · 1 configurations
Application
layuilayui
< 2.7.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for layui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update layui to 2.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-50550 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.
O3 Security · Impact-Aware SCA

Is CVE-2023-50550 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-50550: layui XSS — Fixed in 2.7.5