NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2023-50422 — java-security

CRITICALFix: SAP/cloud-security-services-integration-library@4b3e42a

CVE-2023-50422 is a critical-severity (CVSS 9.1) CWE-749 vulnerability in com.sap.cloud.security:java-security. A fix is available for com.sap.cloud.security:java-security — see the affected versions and patch details below.

Escalation of Privileges in SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library)

Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.04%0.64%1.25%1.85%0.5%1.4%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕com.sap.cloud.security:java-security☕com.sap.cloud.security:java-security☕com.sap.cloud.security:spring-security☕com.sap.cloud.security:spring-security☕com.sap.cloud.security.xsuaa:spring-xsuaa☕com.sap.cloud.security.xsuaa:spring-xsuaa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application.

Patches

Upgrade to patched version >= 2.17.0 or >= 3.3.0 We always recommend to upgrade to the latest released version.

Workarounds

No workarounds

References

https://www.cve.org/CVERecord?id=CVE-2023-50422

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.sap.cloud.security:java-securityall versions2.17.0com.sap.cloud.security:java-security:2.17.0
☕Mavencom.sap.cloud.security:java-security≥ 3.0.0&&< 3.3.03.3.0com.sap.cloud.security:java-security:3.3.0
☕Mavencom.sap.cloud.security:spring-securityall versions2.17.0com.sap.cloud.security:spring-security:2.17.0
☕Mavencom.sap.cloud.security:spring-security≥ 3.0.0&&< 3.3.03.3.0com.sap.cloud.security:spring-security:3.3.0
☕Mavencom.sap.cloud.security.xsuaa:spring-xsuaaall versions2.17.0com.sap.cloud.security.xsuaa:spring-xsuaa:2.17.0
☕Mavencom.sap.cloud.security.xsuaa:spring-xsuaa≥ 3.0.0&&< 3.3.03.3.0com.sap.cloud.security.xsuaa:spring-xsuaa:3.3.0

Affected Products

1 product · 2 configurations
Application
cloud-security-services-integration-librarysap
≥ 3.0.0 && < 3.3.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.sap.cloud.security:java-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.sap.cloud.security:java-security to 2.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-50422 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application. ### Patches Upgrade to patched version >= 2.17.0 or >= 3.3.0 We always recommend to upgrade to the latest released version. ### Workarounds No workarounds ### References https://www.cve.org/CVERecord?id=CVE-2023-50422
O3 Security · Impact-Aware SCA

Is CVE-2023-50422 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-50422: java-security — Fixed in 2.17.0