CVE-2026-54753 is a medium-severity (CVSS 5.9) CWE-749 vulnerability in nx. A fix is available for nx — see the affected versions and patch details below.
Nx: `nx graph` dev server permissive CORS policy
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-54753.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
nxnpmDescription
Summary
The local HTTP server started by nx graph sent Access-Control-Allow-Origin: * on every response, letting any website a developer visited read the server's responses cross-origin — including the full project graph and the output of the /help endpoint, which runs a target's configured help command. The practical impact is typically cross-origin information disclosure, but can be arbitrary command injection in rare cases.
Severity
Exploitation requires the developer to be running nx graph and to visit an attacker page. Any execution beyond benign help commands also requires a malicious target to already be present in the workspace (see Details).
Affected & Patched Versions
Package: nx (npm).
- Affected:
>= 17.0.4, < 22.7.2and>= 23.0.0-beta.0, < 23.0.0-beta.2 - Patched:
22.7.2+ (backport) and23.0.0(first in23.0.0-beta.2)
The wildcard CORS header was introduced in 17.0.4; the /help execution endpoint in 19.4.0. The 21.x line is not patched — 21.x users should upgrade to 22.7.2 or later.
Details
nx graph starts a local server (default http://127.0.0.1:4211). Before the fix, its request handler set a wildcard CORS header on every response:
res.setHeader('Access-Control-Allow-Origin', '*');
The /help endpoint runs a target's configured command:
const command = target.metadata?.help?.command;
return execSync(command, { cwd: target.options?.cwd ?? workspaceRoot }).toString();
A GET /help is a CORS "simple request", so a malicious page could fetch() it with no preflight, and the wildcard header let the page read the result. This exposes the project graph (project names, file paths, dependencies, build configuration) and the output of any configured help command.
The command is not attacker-controlled through the request — it comes from the workspace's project configuration, and first-party plugins (jest, vite, cypress) populate it with benign, read-only help commands. For /help to run anything malicious, a target carrying a malicious help.command must already exist in the project graph, which can only be introduced by installing a malicious package or by altering the workspace's own code/configuration — both of which already grant code execution independent of this flaw.
The fix (#35494) removes the header; the browser's same-origin policy then blocks cross-origin reads.
References
- Fix: nrwl/nx#35494
- Introduced: nrwl/nx#20744 (CORS), nrwl/nx#26629 (
/help)
Credits
Thanks to Nozomu Sasaki (Paul) (@morimori-dev) for finding and responsibly reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | nx | ≥ 17.0.4&&< 22.7.2 | 22.7.2npm install nx@22.7.2 |
| 📦npm | nx | ≥ 23.0.0-beta.0&&< 23.0.0-beta.2 | 23.0.0-beta.2npm install nx@23.0.0-beta.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nx, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nx to 22.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-54753 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2026-54753 in your dependencies?
Find it across npm, including transitive dependencies.