CVE-2023-48631 is a medium-severity (CVSS 5) Improper Input Validation vulnerability in @adobe/css-tools. A fix is available for @adobe/css-tools — see the affected versions and patch details below.
@adobe/css-tools Improper Input Validation and Inefficient Regular Expression Complexity
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@adobe/css-toolsnpmDescription
Impact
@adobe/css-tools version 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.
Patches
The issue has been resolved in 4.3.2.
Workarounds
None
References
N/A
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @adobe/css-tools | all versions | 4.3.2npm install @adobe/css-tools@4.3.2 |
Affected Products
css-toolsadobeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @adobe/css-tools, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @adobe/css-tools to 4.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-48631 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Regular Expression Denial of Service (ReDoS) vulnerability in css-tools, triggered by improper input validation when parsing CSS, is considered of moderate severity. While it can lead to a denial of service by causing the application to become unresponsive, the impact is limited to scenarios where an attacker can…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2023-48631 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Migration Toolkit for Runtimes 1 on RHEL 8 | mtr/mtr-operator-bundle:1.2-23 | RHSA-2024:3919 |
| MTA-6.2-RHEL-9 | mta/mta-windup-addon-rhel9:6.2.3-2 | RHSA-2024:3989 |
| MTA-7.0-RHEL-9 | mta/mta-cli-rhel9:7.0.3-16 | RHSA-2024:3316 |
| RHDH-1.1-RHEL-9 | rhdh/rhdh-hub-rhel9:1.1-97 | RHEA-2024:1366 |
| RHODF-4.15-RHEL-9 | odf4/odf-console-rhel9:v4.15.0-57 | RHSA-2024:1383 |
Frequently Asked Questions
Is CVE-2023-48631 in your dependencies?
Find it across npm, including transitive dependencies.