NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2023-46499 — @evershop/evershop

MEDIUMFix: evershopcommerce/evershop#244

CVE-2023-46499 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in @evershop/evershop. A fix is available for @evershop/evershop — see the affected versions and patch details below.

Cross-site Scripting in evershop

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-46499.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

10other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@evershop/evershopnpm
2Kdownloads / week

Description

Cross Site Scripting vulnerability in EverShop NPM versions before v.1.0.0-rc.5 allows a remote attacker to obtain sensitive information via a crafted scripts to the Admin Panel.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@evershop/evershopall versions1.0.0-rc.5npm install @evershop/evershop@1.0.0-rc.5

Affected Products

1 product · 9 configurations
Application
evershopevershop
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @evershop/evershop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @evershop/evershop to 1.0.0-rc.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-46499 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross Site Scripting vulnerability in EverShop NPM versions before v.1.0.0-rc.5 allows a remote attacker to obtain sensitive information via a crafted scripts to the Admin Panel.
O3 Security · Impact-Aware SCA

Is CVE-2023-46499 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-46499: @evershop/evershop — Fixed in 1.0.0-rc.5