NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2023-46942 — @evershop/evershop

HIGHFix: evershopcommerce/evershop@6e16f04

CVE-2023-46942 is a high-severity (CVSS 7.5) Improper Authentication vulnerability in @evershop/evershop. A fix is available for @evershop/evershop — see the affected versions and patch details below.

EverShop vulnerable to improper authorization in GraphQL endpoints

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-46942.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.1%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

10other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@evershop/evershopnpm
2Kdownloads / week

Description

Lack of authentication in NPM's package @evershop/evershop before version 1.0.0-rc.9, allows remote attackers to obtain sensitive information via improper authorization in GraphQL endpoints.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@evershop/evershopall versions1.0.0-rc.9npm install @evershop/evershop@1.0.0-rc.9

Affected Products

1 product · 12 configurations
Application
evershopevershop
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @evershop/evershop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @evershop/evershop to 1.0.0-rc.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-46942 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Lack of authentication in NPM's package @evershop/evershop before version 1.0.0-rc.9, allows remote attackers to obtain sensitive information via improper authorization in GraphQL endpoints.
O3 Security · Impact-Aware SCA

Is CVE-2023-46942 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-46942: @evershop/evershop — Fixed in 1.0.0-rc.9