NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2023-46496 — @evershop/evershop

HIGHFix: evershopcommerce/evershop#338

CVE-2023-46496 is a high-severity (CVSS 8.3) Path Traversal vulnerability in @evershop/evershop. A fix is available for @evershop/evershop — see the affected versions and patch details below.

Directory Traversal in evershop

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.56%1.12%1.69%0.5%1.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

10other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@evershop/evershopnpm
778downloads / week

Description

Directory Traversal vulnerability in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information via a crafted request to the DELETE function in api/files endpoint.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@evershop/evershopall versions1.0.0-rc.8npm install @evershop/evershop@1.0.0-rc.8

Affected Products

1 product · 12 configurations
Application
evershopevershop
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @evershop/evershop, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @evershop/evershop to 1.0.0-rc.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-46496 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Directory Traversal vulnerability in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information via a crafted request to the DELETE function in api/files endpoint.
O3 Security · Impact-Aware SCA

Is CVE-2023-46496 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-46496: @evershop/evershop — Fixed in 1.0.0-rc.8