CVE-2023-45819 — tinymce
MEDIUMCVE-2023-45819 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in tinymce. A fix is available for tinymce — see the affected versions and patch details below.
Cross-site Scripting vulnerability in TinyMCE notificationManager.open API
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-45819.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
tinymcenpmDescription
Impact
A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s Notification Manager API. The vulnerability exploits TinyMCE's unfiltered notification system, which is used in error handling. The conditions for this exploit requires carefully crafted malicious content to have been inserted into the editor and a notification to have been triggered.
When a notification was opened, the HTML within the text argument was displayed unfiltered in the notification. The vulnerability allowed arbitrary JavaScript execution when an notification presented in the TinyMCE UI for the current user. This issue could also be exploited by any integration which uses a TinyMCE notification to display unfiltered HTML content.
Patches
This vulnerability has been patched in TinyMCE 5.10.8 and TinyMCE 6.7.1 by ensuring that the HTML displayed in the notification is sanitized, preventing the exploit.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 5.10.8 or higher for TinyMCE 5.x.
- Upgrade to TinyMCE 6.7.1 or higher for TinyMCE 6.x.
References
- https://tiny.cloud/docs/release-notes/release-notes5108/#securityfixes
- https://tiny.cloud/docs/tinymce/6/6.7.1-release-notes/#security-fixes
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
- Open an issue in the TinyMCE repo
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | tinymce | ≥ 6.0.0&&< 6.7.1 | 6.7.1npm install tinymce@6.7.1 |
| 📦npm | tinymce | all versions | 5.10.8npm install tinymce@5.10.8 |
| .NETNuGet | TinyMCE | ≥ 6.0.0&&< 6.7.1 | 6.7.1dotnet add package TinyMCE --version 6.7.1 |
| .NETNuGet | TinyMCE | all versions | 5.10.8dotnet add package TinyMCE --version 5.10.8 |
| 🐘Packagist | tinymce/tinymce | ≥ 6.0.0&&< 6.7.1 | 6.7.1composer require tinymce/tinymce:^6.7.1 |
| 🐘Packagist | tinymce/tinymce | all versions | 5.10.8composer require tinymce/tinymce:^5.10.8 |
Affected Products
tinymcetinyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tinymce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tinymce to 6.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-45819 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-45819 in your dependencies?
Find it across npm, NuGet, Packagist, including transitive dependencies.