NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2023-45278 — yamcs

CRITICAL

CVE-2023-45278 is a critical-severity (CVSS 9.1) Path Traversal vulnerability in org.yamcs:yamcs. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.yamcs:yamcs — see the affected versions and patch details below.

Yamcs API Directory Traversal vulnerability

Also known asGHSA-43fw-536j-w37j
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk+0.25%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
1.08%1.87%2.67%3.46%3.0%1.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.yamcs:yamcs

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.yamcs:yamcsall versions5.8.7org.yamcs:yamcs:5.8.7

Affected Products

1 product · 1 configurations
Application
yamcsspaceapplications
1 version
5.8.6
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.yamcs:yamcs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.yamcs:yamcs to 5.8.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-45278 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
O3 Security · Impact-Aware SCA

Is CVE-2023-45278 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-45278: yamcs Path Traversal — Fixed in 5.8.7