NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-4451 — cockpit

MEDIUMFix: cockpit-hq/cockpit@3060946

CVE-2023-4451 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in cockpit-hq/cockpit. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

Cross-site Scripting (XSS) - Reflected in cockpit-hq/cockpit

Also known asGHSA-g3mv-64h3-h482
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
1 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-4451.

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk-0.02%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%27.3%54.7%82.0%63.6%2.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘cockpit-hq/cockpit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) - Reflected in GitHub repository cockpit-hq/cockpit version 2.6.3 and prior. A patch is available at commit 30609466c817e39f9de1871559603e93cd4d0d0c and anticipated to be part of version 2.6.4.

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
🐘Packagistcockpit-hq/cockpitall versionsNo fix

Affected Products

1 product · 1 configurations
Application
cockpitagentejo
≤ 2.6.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cockpit-hq/cockpit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of cockpit-hq/cockpit for CVE-2023-4451. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2023-4451

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-4451 -u https://target
Template
Cockpit - Cross-Site Scripting
Severity
medium
Impact
Unauthenticated attackers can inject malicious JavaScript through the space parameter in the installation interface to steal administrator credentials during Cockpit CMS setup.
Remediation
Update Cockpit to version 2.6.4 or later that properly sanitizes and encodes the space parameter in the install/index.php interface.

Template by ProjectDiscovery nuclei-templates (iamnoooob, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Cross-site Scripting (XSS) - Reflected in GitHub repository cockpit-hq/cockpit version 2.6.3 and prior. A patch is available at commit 30609466c817e39f9de1871559603e93cd4d0d0c and anticipated to be part of version 2.6.4.
O3 Security · Impact-Aware SCA

Is CVE-2023-4451 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-4451: cockpit XSS (Medium 6.1)