CVE-2023-44389 is a low-severity (CVSS 3.1) Cross-site Scripting (XSS) vulnerability in zope. A fix is available for zope — see the affected versions and patch details below.
Zope management interface vulnerable to stored cross site scripting via the title property
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-44389.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zope🐍zopeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The title property, available on most Zope objects, can be used to store script code that is executed while viewing the affected object in the Zope Management Interface (ZMI) because the title property is displayed unquoted in the breadcrumbs element. All versions of Zope 4 and Zope 5 are affected.
Patches
Patches will be released with Zope versions 4.8.11 and 5.8.6.
Workarounds
Make sure only Manager users can edit and view Zope objects in the Zope Management Interface. This is the default.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | zope | ≥ 4.0.0&&< 4.8.11 | 4.8.11pip install --upgrade 'zope==4.8.11' |
| 🐍PyPI | zope | ≥ 5.0.0&&< 5.8.6 | 5.8.6pip install --upgrade 'zope==5.8.6' |
Affected Products
zopezopeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zope, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zope to 4.8.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-44389 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-44389 in your dependencies?
Find it across PyPI, including transitive dependencies.