NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-43502 — build-failure-analyzer

MEDIUMFix: jenkinsci/build-failure-analyzer-plugin@a261229

CVE-2023-43502 is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer. A fix is available for com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer — see the affected versions and patch details below.

Jenkins Build Failure Analyzer Plugin Cross-Site Request Forgery vulnerability

Also known asGHSA-2wwh-qgh8-w9xw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-43502.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.30%0.59%0.89%0.0%0.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Build Failure Analyzer Plugin 2.4.1 and earlier does not require POST requests for an HTTP endpoint, resulting in cross-site request forgery (CSRF) vulnerabilities.

This vulnerability allows attackers to delete Failure Causes.

Build Failure Analyzer Plugin 2.4.2 requires POST requests for the affected HTTP endpoint.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.sonyericsson.jenkins.plugins.bfa:build-failure-analyzerall versions2.4.2com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer:2.4.2

Affected Products

1 product · 1 configurations
Application
build failure analyzerjenkins
< 2.4.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer to 2.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-43502 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Jenkins Build Failure Analyzer Plugin 2.4.1 and earlier does not require POST requests for an HTTP endpoint, resulting in cross-site request forgery (CSRF) vulnerabilities. This vulnerability allows attackers to delete Failure Causes. Build Failure Analyzer Plugin 2.4.2 requires POST requests for the affected HTTP endpoint.
O3 Security · Impact-Aware SCA

Is CVE-2023-43502 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-43502: build-failure CSRF — Fixed in 2.4.2