NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-16553 — build-failure-analyzer

HIGHFix: jenkinsci/build-failure-analyzer-plugin@f316c88

CVE-2019-16553 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer. A fix is available for com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer — see the affected versions and patch details below.

Cross-Site Request Forgery in Jenkins Build Failure Analyzer Plugin

Also known asGHSA-543w-gq76-pw7g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk+0.17%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site request forgery vulnerability in Jenkins Build Failure Analyzer Plugin 1.24.1 and earlier allows attackers to have Jenkins evaluate a computationally expensive regular expression.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.sonyericsson.jenkins.plugins.bfa:build-failure-analyzerall versions1.24.2com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer:1.24.2

Affected Products

1 product · 1 configurations
Application
build failure analyzerjenkins
≤ 1.24.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer to 1.24.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16553 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A cross-site request forgery vulnerability in Jenkins Build Failure Analyzer Plugin 1.24.1 and earlier allows attackers to have Jenkins evaluate a computationally expensive regular expression.
O3 Security · Impact-Aware SCA

Is CVE-2019-16553 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-16553: build-failure CSRF — Fixed in 1.24.2