NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-4218 — org.eclipse.core.runtime

MEDIUMFix: eclipse-cdt/cdt@c7169b3

CVE-2023-4218 is a medium-severity (CVSS 5) XML External Entity (XXE) vulnerability in org.eclipse.platform:org.eclipse.core.runtime. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.eclipse.platform:org.eclipse.core.runtime — see the affected versions and patch details below.

XXE in eclipse.platform / Eclipse IDE

Also known asGHSA-j24h-xcpc-9jw8
Published
Updated
Affected
8 pkgs
Patched
8 / 8
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-4218.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.30%0.59%0.89%0.0%0.4%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

8 pkgs affected
☕org.eclipse.platform:org.eclipse.core.runtime☕org.eclipse.platform:org.eclipse.platform☕org.eclipse.platform:org.eclipse.jface☕org.eclipse.platform:org.eclipse.ui.forms☕org.eclipse.platform:org.eclipse.ui.ide☕org.eclipse.platform:org.eclipse.ui.workbench☕org.eclipse.platform:org.eclipse.urischeme☕org.eclipse.jdt:org.eclipse.jdt.ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

xml files like ".project" are parsed vulnerable against all sorts of XXE attacks. The user just needs to open any evil project or update an open project with a vulnerable file (for example for review a foreign repository or patch).

Vulnerablility was found by static code analysis (SonarLint).

Example .project file:

<?xml version="1.0" encoding="utf-8"?> 
<!DOCTYPE price [
<!ENTITY xxe SYSTEM "http://127.0.0.1:49416/evil">]>
<projectDescription>
	<name>p</name>
	<comment>&xxe;</comment>
</projectDescription>

Patches

Similar patches including junit test that shows the vulnerability have already applied to PDE (see https://github.com/eclipse-pde/eclipse.pde/pull/667). A solution to platform should be the same: just reject parsing any XML that contains any DOCTYPE.

Workarounds

No known workaround. User can only avoid to get/open any foreign files with eclipse. Firewall rules against loss of data (but not against XML bomb).

References

https://cwe.mitre.org/data/definitions/611.html https://rules.sonarsource.com/java/RSPEC-2755 https://gitlab.eclipse.org/security/vulnerability-reports/-/issues/8 (Report for multiple projects affected)

Affected Packages

8 total 8 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.eclipse.platform:org.eclipse.core.runtimeall versions3.29.0org.eclipse.platform:org.eclipse.core.runtime:3.29.0
☕Mavenorg.eclipse.platform:org.eclipse.platformall versions4.29.0org.eclipse.platform:org.eclipse.platform:4.29.0
☕Mavenorg.eclipse.platform:org.eclipse.jfaceall versions3.31.0org.eclipse.platform:org.eclipse.jface:3.31.0
☕Mavenorg.eclipse.platform:org.eclipse.ui.formsall versions3.13.0org.eclipse.platform:org.eclipse.ui.forms:3.13.0
☕Mavenorg.eclipse.platform:org.eclipse.ui.ideall versions3.21.100org.eclipse.platform:org.eclipse.ui.ide:3.21.100
☕Mavenorg.eclipse.platform:org.eclipse.ui.workbenchall versions3.130.0org.eclipse.platform:org.eclipse.ui.workbench:3.130.0

Affected Products

3 products · 3 configurations
Application
eclipse ideeclipse
< 4.29
range
Application
org.eclipse.core.runtimeeclipse
< 3.29.0
range
Application
pdeeclipse
< 3.13.2400
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.platform:org.eclipse.core.runtime, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.eclipse.platform:org.eclipse.core.runtime to 3.29.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-4218 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact xml files like ".project" are parsed vulnerable against all sorts of XXE attacks. The user just needs to open any evil project or update an open project with a vulnerable file (for example for review a foreign repository or patch). Vulnerablility was found by static code analysis (SonarLint). Example `.project` file: ``` <?xml version="1.0" encoding="utf-8"?> <!DOCTYPE price [ <!ENTITY xxe SYSTEM "http://127.0.0.1:49416/evil">]> <projectDescription> <name>p</name> <comment>&xxe;</comment> </projectDescription> ``` ### Patches Similar patches including junit test that shows th
O3 Security · Impact-Aware SCA

Is CVE-2023-4218 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-4218: org.eclipse.core XXE — Fixed in 3.29.0