NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-4136 — crafter-engine

MEDIUM

CVE-2023-4136 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.craftercms:crafter-engine. A fix is available for org.craftercms:crafter-engine — see the affected versions and patch details below.

Cross-site Scripting (XSS) in CrafterCMS

Also known asGHSA-jfm4-3vv3-fm4v
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-4136.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%10.7%21.4%32.0%24.9%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.craftercms:crafter-engine☕org.craftercms:crafter-engine

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CrafterCMS Engine on Windows, MacOS, Linux, x86, ARM, 64 bit allows Reflected XSS.This issue affects CrafterCMS: from 4.0.0 through 4.0.2, from 3.1.0 through 3.1.27.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.craftercms:crafter-engine≥ 4.0.0&&< 4.0.34.0.3org.craftercms:crafter-engine:4.0.3
☕Mavenorg.craftercms:crafter-engine≥ 3.1.0&&< 3.1.283.1.28org.craftercms:crafter-engine:3.1.28

Affected Products

1 product · 2 configurations
Application
craftercmscraftercms
≥ 4.0.0 && ≤ 4.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.craftercms:crafter-engine, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.craftercms:crafter-engine to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-4136 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2023-4136

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2023-4136 -u https://target
Template
CrafterCMS Engine - Cross-Site Scripting
Severity
medium
Impact
Unauthenticated attackers can inject malicious JavaScript through the transformerName parameter in various API endpoints to steal CrafterCMS user credentials and session data.
Remediation
Update CrafterCMS Engine to the latest version that addresses this vulnerability.

Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CrafterCMS Engine on Windows, MacOS, Linux, x86, ARM, 64 bit allows Reflected XSS.This issue affects CrafterCMS: from 4.0.0 through 4.0.2, from 3.1.0 through 3.1.27.
O3 Security · Impact-Aware SCA

Is CVE-2023-4136 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-4136: crafter-engine XSS — Fixed in 4.0.3