CVE-2023-41057 is a medium-severity (CVSS 5.5) Path Traversal vulnerability in hyper-bump-it. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for hyper-bump-it — see the affected versions and patch details below.
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in hyper-bump-it
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-41057.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
hyper-bump-itReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
hyper-bump-it reads a file glob pattern from the configuration file. That is combined with the project root directory to construct a full glob pattern that is used to find files that should be edited. These matched files should be contained within the project root directory, but that is not checked. This could result in changes being written to files outside of the project.
The default behaviour of hyper-bump-it is to display the planned changes and prompt the user for confirmation before editing any files. However, the configuration file provides a field that can be used cause files to be edited without displaying the prompt.
Details
The vulnerability is present in
That code joins the project root directory with a string read from the configuration file without checking if the final path is located outside the project root directory.
The following configuration file contents would cause hyper-bump-it to replace every instance of "hello" in every file adjacent to the project root directory with "world". The line setting show_confirm_prompt to false is not required, but will result in the user file edits to occur without the user having a chance to reject the changes (The fact that changes happened would still be displayed).
[hyper-bump-it]
current_version = "1.2.3"
show_confirm_prompt=false
[[hyper-bump-it.files]]
file_glob = "../*"
search_format_pattern = "hello"
replace_format_pattern = "world"
Patches
A fix that been released as part of v0.5.1. The changes can be view as part of PR #307.
Workarounds
Users that are unable to update from vulnerable versions, executing hyper-bump-it with the --interactive command line argument will ensure that all planned changes are displayed and prompt the user for confirmation before editing any files, even if the configuration file contains show_confirm_prompt=true.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | hyper-bump-it | all versions | 0.5.1pip install --upgrade 'hyper-bump-it==0.5.1' |
Affected Products
hyper bump itplanniganResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hyper-bump-it, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update hyper-bump-it to 0.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-41057 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2023-41057 in your dependencies?
Find it across PyPI, including transitive dependencies.