CVE-2023-41050 is a medium-severity (CVSS 6.8) Information Exposure vulnerability in accesscontrol. A fix is available for accesscontrol — see the affected versions and patch details below.
Information disclosure through Python's "format" functionality in Zope AccessControl
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-41050.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
accesscontrol🐍zope🐍accesscontrol🐍accesscontrol🐍zopeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
AccessControl provides a general security framework for use in Zope. Python's "format" functionality allows someone controlling the format string to "read" objects accessible (recursively) via attribute access and subscription from accessible objects. Those attribute accesses and subscriptions use Python's full blown getattr and getitem, not the policy restricted AccessControl variants _getattr_ and _getitem_. This can lead to critical information disclosure. AccessControl already provides a safe variant for str.format and denies access to string.Formatter. However, str.format_map is still unsafe. Affected are all users who allow untrusted users to create AccessControl controlled Python code and execute it. A fix has been introduced in versions 4.4, 5.8 and 6.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | accesscontrol | all versions | 4.4pip install --upgrade 'accesscontrol==4.4' |
| 🐍PyPI | zope | all versions | 4.8.9pip install --upgrade 'zope==4.8.9' |
| 🐍PyPI | accesscontrol | ≥ 5.0&&< 5.8 | 5.8pip install --upgrade 'accesscontrol==5.8' |
| 🐍PyPI | accesscontrol | ≥ 6.0&&< 6.2 | 6.2pip install --upgrade 'accesscontrol==6.2' |
| 🐍PyPI | zope | ≥ 5.0.0&&< 5.8.4 | 5.8.4pip install --upgrade 'zope==5.8.4' |
Affected Products
accesscontrolzopezopezopeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for accesscontrol, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update accesscontrol to 4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-41050 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2023-41050 in your dependencies?
Find it across PyPI, including transitive dependencies.