NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-40579 — openfga

MEDIUM

CVE-2023-40579 is a medium-severity (CVSS 6.5) CWE-284 vulnerability in github.com/openfga/openfga. A fix is available for github.com/openfga/openfga — see the affected versions and patch details below.

OpenFGA Authorization Bypass

Also known asGHSA-jcf2-mxr2-gmqpGO-2023-2028
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 21, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-40579.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/openfga/openfga

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Overview

Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. This means that the API sometimes returns more objects than it should.

Am I Affected?

The vulnerability affects customers using ListObjects with specific models. The affected models contain expressions of type rel1 from type1.

Fix

Update to v1.3.1.

Backward Compatibility

This update is backward compatible.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/openfga/openfgaall versions1.3.1go get github.com/openfga/openfga@v1.3.1

Affected Products

1 product · 1 configurations
Application
openfgaopenfga
< 1.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/openfga/openfga, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/openfga/openfga to 1.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-40579 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

## Overview Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. This means that the API sometimes returns more objects than it should. ## Am I Affected? The vulnerability affects customers using ListObjects with specific models. The affected models contain expressions of type `rel1 from type1`. ## Fix Update to v1.3.1. ## Backward Compatibility This update is backward compatible.
O3 Security · Impact-Aware SCA

Is CVE-2023-40579 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-40579: openfga — Fixed in 1.3.1