CVE-2023-40025 is a medium-severity (CVSS 4.7) CWE-613 vulnerability in github.com/argoproj/argo-cd/v2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/argoproj/argo-cd/v2 — see the affected versions and patch details below.
Argo CD web terminal session doesn't expire
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-40025.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
All versions of Argo CD starting from v2.6.0 have a bug where open web terminal sessions do not expire. This bug allows users to send any websocket messages even if the token has already expired. The most straightforward scenario is when a user opens the terminal view and leaves it open for an extended period. This allows the user to view sensitive information even when they should have been logged out already.
Patches
A patch for this vulnerability has been released in the following Argo CD version:
- v2.6.14
- v2.7.12
- v2.8.1
Workarounds
The only way to completely resolve the issue is to upgrade.
Mitigations
Disable web-based terminal or define RBAC rules to it https://argo-cd.readthedocs.io/en/latest/operator-manual/web_based_terminal/
For more information
If you have any questions or comments about this advisory:
- Open an issue in the Argo CD issue tracker or discussions
- Join us on Slack in channel #argo-cd
Credits
Thank you to bean.zhang (@zhlu32 ) of HIT-IDS ChunkL Team who discovered the issue and reported it confidentially according to our guidelines.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.6.0&&< 2.6.14 | 2.6.14go get github.com/argoproj/argo-cd/v2@v2.6.14 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.7.0&&< 2.7.12 | 2.7.12go get github.com/argoproj/argo-cd/v2@v2.7.12 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.8.0&&< 2.8.1 | 2.8.1go get github.com/argoproj/argo-cd/v2@v2.8.1 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.0.0-20230718200744-12a5a7a70d6e&&< 2.0.0-20230821201509-e047efa8f951 | 2.0.0-20230821201509-e047efa8f951go get github.com/argoproj/argo-cd/v2@v2.0.0-20230821201509-e047efa8f951 |
Affected Products
argo cdargoprojResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/argoproj/argo-cd/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/argoproj/argo-cd/v2 to 2.6.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-40025 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift GitOps 1.11 | openshift-gitops-1/argocd-rhel8:v1.11.7-2 | RHSA-2024:4972 |
| Red Hat OpenShift GitOps 1.12 | openshift-gitops-1/argocd-rhel8:v1.12.5-5 | RHSA-2024:4973 |
Frequently Asked Questions
Is CVE-2023-40025 in your dependencies?
Find it across Go, including transitive dependencies.