CVE-2023-39347 — cilium
HIGHCVE-2023-39347 is a high-severity (CVSS 7.6) CWE-345 vulnerability in github.com/cilium/cilium. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/cilium/cilium — see the affected versions and patch details below.
Cilium NetworkPolicy bypass via pod labels
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-39347.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/cilium/cilium🐹github.com/cilium/cilium🐹github.com/cilium/ciliumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An attacker with the ability to update pod labels can cause Cilium to apply incorrect network policies.
This issue arises due to the fact that on pod update, Cilium incorrectly uses user-provided pod labels to select the policies which apply to the workload in question.
This can affect:
- Cilium network policies that use the namespace, service account or cluster constructs to restrict traffic
- Cilium clusterwide network policies that use Cilium namespace labels to select the Pod
- Kubernetes network policies
Non-existent construct names can be provided, which bypass all network policies applicable to the construct. For example, providing a pod with a non-existent namespace as the value of the io.kubernetes.pod.namespace label results in none of the namespaced CiliumNetworkPolicies applying to the pod in question.
This attack requires the attacker to have Kubernetes API Server access, as described in the Cilium Threat Model.
Patches
This issue affects:
- Cilium <= v1.14.1
- Cilium <= v1.13.6
- Cilium <= v1.12.13
This issue has been resolved in:
- Cilium v1.14.2
- Cilium v1.13.7
- Cilium v1.12.14
Workarounds
An admission webhook can be used to prevent pod label updates to the k8s:io.kubernetes.pod.namespace and io.cilium.k8s.policy.* keys.
Acknowledgements
The Cilium community has worked together with members of Palantir and Isovalent to prepare these mitigations. Special thanks to @odinuge for reporting this issue and to @nebril for the fix.
For more information
If you have any questions or comments about this advisory, please reach out on Slack.
If you think you have found a vulnerability in Cilium, we strongly encourage you to report it to our private security mailing list – [email protected] – first, before disclosing them in any public forums. This is a private mailing list where only members of the Cilium internal security team are subscribed to, and is treated as top priority.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/cilium/cilium | ≥ 1.13.0&&< 1.13.7 | 1.13.7go get github.com/cilium/cilium@v1.13.7 |
| 🐹Go | github.com/cilium/cilium | ≥ 1.14.0&&< 1.14.2 | 1.14.2go get github.com/cilium/cilium@v1.14.2 |
| 🐹Go | github.com/cilium/cilium | all versions | 1.12.14go get github.com/cilium/cilium@v1.12.14 |
Affected Products
ciliumciliumResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cilium/cilium, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/cilium/cilium to 1.13.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-39347 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-39347 in your dependencies?
Find it across Go, including transitive dependencies.