NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-39062 — html2pdf

MEDIUMFix: spipu/html2pdf@92afd81

CVE-2023-39062 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in spipu/html2pdf. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for spipu/html2pdf — see the affected versions and patch details below.

Spipu HTML2PDF vulnerable to cross-site scripting

Also known asGHSA-99fg-2h75-m92h
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-39062.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%15.2%30.5%45.7%35.5%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘spipu/html2pdf

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross Site Scripting vulnerability in Spipu HTML2PDF before v.5.2.8 allows a remote attacker to execute arbitrary code via a crafted script to the forms.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistspipu/html2pdfall versions5.2.8composer require spipu/html2pdf:^5.2.8

Affected Products

1 product · 1 configurations
Application
html2pdfhtml2pdf_project
< 5.2.8
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for spipu/html2pdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update spipu/html2pdf to 5.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-39062 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross Site Scripting vulnerability in Spipu HTML2PDF before v.5.2.8 allows a remote attacker to execute arbitrary code via a crafted script to the forms.php.
O3 Security · Impact-Aware SCA

Is CVE-2023-39062 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-39062: html2pdf RCE — Fixed in 5.2.8