NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2023-38704 — import-in-the-middle

HIGHFix: DataDog/import-in-the-middle@2531cdd

CVE-2023-38704 is a high-severity (CVSS 8.1) Improper Input Validation vulnerability in import-in-the-middle. A fix is available for import-in-the-middle — see the affected versions and patch details below.

import-in-the-middle allows unsanitized user controlled input in module generation

Also known asGHSA-5r27-rw8r-7967
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-38704.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.06%0.54%1.02%1.50%0.6%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

116other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
import-in-the-middlenpm
109.8Mdownloads / week

Description

Impact

The import-in-the-middle loader works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. It allows for remote code execution in cases where an application passes user-supplied input directly to an import() function.

Patches

This vulnerability has been patched in import-in-the-middle version 1.4.2

Workarounds

  • Do not pass any user-supplied input to import(). Instead, verify it against a set of allowed values.
  • If using import-in-the-middle and support for EcmaScript Modules is not needed, ensure that none of the following options are set (either via command-line or the NODE_OPTIONS environment variable):
--loader=import-in-the-middle/hook.mjs
--loader import-in-the-middle/hook.mjs

References

If you have any questions or comments about this advisory, email us at [email protected]

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmimport-in-the-middleall versions1.4.2npm install import-in-the-middle@1.4.2

Affected Products

1 product · 1 configurations
Application
import-in-the-middledatadoghq
< 1.4.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for import-in-the-middle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update import-in-the-middle to 1.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-38704 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact The `import-in-the-middle` loader works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. It allows for remote code execution in cases where an application passes user-supplied input directly to an import() function. ### Patches This vulnerability has been patched in `import-in-the-middle` version 1.4.2 ### Workarounds * Do not pass any user-supplied input to `import()`. Instead, verify it against a set of allowed values. * If using `import-in-the-middle` and support for EcmaScript Modules is no
O3 Security · Impact-Aware SCA

Is CVE-2023-38704 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2023-38704: import-in-the-middle RCE — Fixed in 1.4.2