CVE-2023-38489 is a high-severity (CVSS 7.3) CWE-613 vulnerability in getkirby/cms. A fix is available for getkirby/cms — see the affected versions and patch details below.
Kirby vulnerable to Insufficient Session Expiration after a password change
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-38489.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cms🐘getkirby/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TL;DR
This vulnerability affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config).
It can only be abused if a Kirby user is logged in on a device or browser that is shared with potentially untrusted users or if an attacker already maliciously used a previous password to log in to a Kirby site as the affected user.
Introduction
Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization.
In the variation described in this advisory, it allows attackers to stay logged in to a Kirby site on another device or browser even if the logged in user has since changed their password.
Impact
Kirby did not invalidate old user sessions after the user password was changed by the user or by a site admin.
If a user changed their password to lock out an attacker who was already in possession of the previous password or of a login session on another device or browser, the attacker would not be reliably prevented from accessing the Kirby site as the affected user.
Patches
The problem has been patched in Kirby 3.5.8.3, Kirby 3.6.6.3, Kirby 3.7.5.2, Kirby 3.8.4.1 and Kirby 3.9.6. Please update to one of these or a later version to fix the vulnerability.
In all of the mentioned releases, we have updated the authentication implementation to keep track of the last time the password was changed. If a new password was set since the login, the session is invalidated. To enforce this fix even if the vulnerability was previously abused, all users are logged out from the Kirby site after updating to one of the patched releases.
Credits
Thanks to Shankar Acharya (@5hank4r) for responsibly reporting the identified issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | getkirby/cms | all versions | 3.5.8.3composer require getkirby/cms:^3.5.8.3 |
| 🐘Packagist | getkirby/cms | ≥ 3.6.0&&< 3.6.6.3 | 3.6.6.3composer require getkirby/cms:^3.6.6.3 |
| 🐘Packagist | getkirby/cms | ≥ 3.7.0&&< 3.7.5.2 | 3.7.5.2composer require getkirby/cms:^3.7.5.2 |
| 🐘Packagist | getkirby/cms | ≥ 3.8.0&&< 3.8.4.1 | 3.8.4.1composer require getkirby/cms:^3.8.4.1 |
| 🐘Packagist | getkirby/cms | ≥ 3.9.0&&< 3.9.6 | 3.9.6composer require getkirby/cms:^3.9.6 |
Affected Products
kirbygetkirbyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getkirby/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update getkirby/cms to 3.5.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-38489 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-38489 in your dependencies?
Find it across Packagist, including transitive dependencies.