CVE-2023-37909 is a critical-severity (CVSS 9.9) CWE-95 vulnerability in org.xwiki.platform:xwiki-platform-menu. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-menu — see the affected versions and patch details below.
Privilege escalation (PR)/remote code execution from account through Menu.UIExtensionSheet
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-37909.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-menu☕org.xwiki.platform:xwiki-platform-menu-ui☕org.xwiki.platform:xwiki-platform-menu-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Any user who can edit their own user profile can execute arbitrary script macros including Groovy and Python macros that allow remote code execution including unrestricted read and write access to all wiki contents. This can be reproduced with the following steps:
- As an advanced user, use the object editor to add an object of type
UIExtensionClassto your user profile. Set the value "Extension Point ID" to{{/html}}{{async async=false cache=false}}{{groovy}}println("Hello from Groovy!"){{/groovy}}{{/async}} - Open
<xwiki-host>/xwiki/bin/edit/XWiki/<username>?sheet=Menu.UIExtensionSheetwhere<xwiki-host>is the URL of your XWiki installation and<username>is your user name.
If the text Hello from Groovy!" selected="selected"> is displayed in the output, the attack succeeded.
Patches
This has been patched in XWiki 14.10.8 and 15.3 RC1 by adding proper escaping.
Workarounds
The patch can be manually applied to the document Menu.UIExtensionSheet, only three lines need to be changed.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-menu | ≥ 5.1-rc-1&&< 14.10.8 | 14.10.8org.xwiki.platform:xwiki-platform-menu:14.10.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-menu-ui | ≥ 5.1-rc-1&&< 14.10.8 | 14.10.8org.xwiki.platform:xwiki-platform-menu-ui:14.10.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-menu-ui | ≥ 15.0-rc-1&&< 15.3-rc-1 | 15.3-rc-1org.xwiki.platform:xwiki-platform-menu-ui:15.3-rc-1 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-menu, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-menu to 14.10.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37909 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2023-37909 in your dependencies?
Find it across Maven, including transitive dependencies.