CVE-2023-37611 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in neos/media-browser. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for neos/media-browser — see the affected versions and patch details below.
Neos CMS Cross Site Scripting vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
neos/media-browser🐘neos/media-browser🐘neos/media-browser🐘neos/media-browser🐘neos/media-browserReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross Site Scripting (XSS) vulnerability in Neos CMS 8.3.3 allows a remote authenticated attacker to execute arbitrary code via a crafted SVG file uploaded to the neos/management/media component. To make use of this attack vector, the attacker must either be able to upload a maliciously crafted file or coerce someone with the needed access to upload said file to Neos. Even if such a file is uploaded and subsequently delivered, it is possible to use CSP to protect against attacks being executed from such a file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | neos/media-browser | all versions | 7.3.19composer require neos/media-browser:^7.3.19 |
| 🐘Packagist | neos/media-browser | ≥ 8.0.0&&< 8.0.16 | 8.0.16composer require neos/media-browser:^8.0.16 |
| 🐘Packagist | neos/media-browser | ≥ 8.1.0&&< 8.1.11 | 8.1.11composer require neos/media-browser:^8.1.11 |
| 🐘Packagist | neos/media-browser | ≥ 8.2.0&&< 8.2.11 | 8.2.11composer require neos/media-browser:^8.2.11 |
| 🐘Packagist | neos/media-browser | ≥ 8.3.0&&< 8.3.9 | 8.3.9composer require neos/media-browser:^8.3.9 |
Affected Products
neos cmsneosResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neos/media-browser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update neos/media-browser to 7.3.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37611 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-37611 in your dependencies?
Find it across Packagist, including transitive dependencies.