NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2023-37477 — 1Panel

HIGHFix: 1Panel-dev/1Panel@e17b80c

CVE-2023-37477 is a high-severity (CVSS 7.2) OS Command Injection vulnerability in github.com/1Panel-dev/1Panel. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/1Panel-dev/1Panel — see the affected versions and patch details below.

Command injection in firewall ip functionality in 1Panel

Also known asGHSA-p9xf-74xh-mhw5GO-2023-1940
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-37477.

EPSS Exploitation Probability

via FIRST.org ↗
5.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%2.47%4.94%7.41%0.6%5.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/1Panel-dev/1Panel

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

An OS command injection vulnerability exists in 1Panel firewall functionality. A specially-crafted HTTP request can lead to arbitrary command execution. An attacker can make an authenticated HTTP request to trigger this vulnerability.

Details

1Panel firewall functionality /hosts/firewall/ip endpoint read user input without validation, the attacker extends the default functionality of the application, which execute system commands.

PoC

the payload ; sleep 3 # will lead server response in 3 seconds image

the payload ; sleep 6 # will lead server response in 6 seconds image

Impact

An attacker can execute arbitrary code on the target system, which can lead to a complete compromise of the system.

Patches

The vulnerability has been fixed in v1.4.3.

Workarounds

It is recommended to upgrade the version to v1.4.3.

References

If you have any questions or comments about this advisory:

Open an issue in https://github.com/1Panel-dev/1Panel Email us at [email protected]

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/1Panel-dev/1Panelall versions1.4.3go get github.com/1Panel-dev/1Panel@v1.4.3

Affected Products

1 product · 1 configurations
Application
1panelfit2cloud
< 1.4.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/1Panel-dev/1Panel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/1Panel-dev/1Panel to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-37477 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Summary An OS command injection vulnerability exists in 1Panel firewall functionality. A specially-crafted HTTP request can lead to arbitrary command execution. An attacker can make an authenticated HTTP request to trigger this vulnerability. ### Details 1Panel firewall functionality `/hosts/firewall/ip` endpoint read user input without validation, the attacker extends the default functionality of the application, which execute system commands. ### PoC the payload `; sleep 3 #` will lead server response in 3 seconds ![image](https://user-images.githubusercontent.com/4935500/252299676-bc
O3 Security · Impact-Aware SCA

Is CVE-2023-37477 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-37477: 1Panel RCE — Fixed in 1.4.3