NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-36259 — craft-audit

MEDIUMFix: sjelfull/craft-audit#73

CVE-2023-36259 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in superbig/craft-audit. A fix is available for superbig/craft-audit — see the affected versions and patch details below.

Craft CMS Audit Plugin Cross Site Scripting vulnerability

Also known asGHSA-v89q-c273-3p42
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-36259.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs32th percentile — riskier than 32% of all scored CVEsHighest risk
0.00%0.29%0.59%0.88%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘superbig/craft-audit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross Site Scripting (XSS) vulnerability in Craft CMS Audit Plugin before version 3.0.2 allows attackers to execute arbitrary code during user creation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsuperbig/craft-auditall versions3.0.2composer require superbig/craft-audit:^3.0.2

Affected Products

1 product · 1 configurations
Application
craft cmscraftcms
< 3.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for superbig/craft-audit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update superbig/craft-audit to 3.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-36259 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross Site Scripting (XSS) vulnerability in Craft CMS Audit Plugin before version 3.0.2 allows attackers to execute arbitrary code during user creation.
O3 Security · Impact-Aware SCA

Is CVE-2023-36259 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-36259: craft-audit RCE — Fixed in 3.0.2