CVE-2023-35170 is a high-severity (CVSS 8.1) remote code execution vulnerability in github.com/bishopfox/sliver. A fix is available for github.com/bishopfox/sliver — see the affected versions and patch details below.
Silver vulnerable to MitM attack against implants due to a cryptography vulnerability
Real-World Exposure
github.com/bishopfox/sliverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
The current cryptography implementation in Sliver up to version 1.5.39 allows a MitM with access to the corresponding implant binary to execute arbitrary codes on implanted devices via intercepted and crafted responses. (Reserved CVE ID: CVE-2023-34758)
Details
Please see the PoC repo.
PoC
Please also see the PoC repo. To setup a simple PoC environment,
- Generate an implant with its C2 set to the PoC server's address and copy the embedded private implant key and public server key into the config json.
- Run the implant on a separate VM and a
notepad.exewindow should pop up on the implanted VM.
Impact
A successful attack grants the attacker permission to execute arbitrary code on the implanted device.
References
https://github.com/BishopFox/sliver/blob/master/implant/sliver/cryptography/implant.go
https://github.com/BishopFox/sliver/blob/master/implant/sliver/cryptography/crypto.go
https://github.com/tangent65536/Slivjacker
Credits
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/bishopfox/sliver | ≥ 1.5.0&&< 1.5.40 | 1.5.40go get github.com/bishopfox/sliver@v1.5.40 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/bishopfox/sliver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/bishopfox/sliver to 1.5.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-35170 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-35170 in your dependencies?
Find it across Go, including transitive dependencies.