CVE-2023-35151 is a high-severity (CVSS 7.5) CWE-359 vulnerability in org.xwiki.platform:xwiki-platform-rest-server. A fix is available for org.xwiki.platform:xwiki-platform-rest-server — see the affected versions and patch details below.
XWiki Platform may show email addresses in clear in REST results
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-35151.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-rest-server☕org.xwiki.platform:xwiki-platform-rest-server☕org.xwiki.platform:xwiki-platform-rest-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Any user can call a REST endpoint and obtain the obfuscated passwords (even when the mail obfuscation is activated).
For instance, by calling http://localhost:8080/xwiki/rest/wikis/xwiki/spaces/XWiki/pages/U1/objects/XWiki.XWikiUsers/0 when user U1 exists on wiki xwiki.
Patches
The issue has been patched on XWiki 14.4.8, 14.10.6, and 15.1
Workarounds
There is no known workaround. It is advised to upgrade to one of the patched versions.
References
- https://jira.xwiki.org/browse/XWIKI-16138
- https://github.com/xwiki/xwiki-platform/commit/824cd742ecf5439971247da11bfe7e0ad2b10ede
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-rest-server | ≥ 7.3-milestone-1&&< 14.4.8 | 14.4.8org.xwiki.platform:xwiki-platform-rest-server:14.4.8 |
| ☕Maven | org.xwiki.platform:xwiki-platform-rest-server | ≥ 14.5&&< 14.10.6 | 14.10.6org.xwiki.platform:xwiki-platform-rest-server:14.10.6 |
| ☕Maven | org.xwiki.platform:xwiki-platform-rest-server | ≥ 15.0-rc-1&&< 15.1 | 15.1org.xwiki.platform:xwiki-platform-rest-server:15.1 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-rest-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-rest-server to 14.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-35151 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-35151 in your dependencies?
Find it across Maven, including transitive dependencies.