CVE-2023-33192 is a high-severity (CVSS 7.5) CWE-130 vulnerability in ntpd. A fix is available for ntpd — see the affected versions and patch details below.
Improper handling of NTS cookie length that could crash the ntpd-rs server
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-33192.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ntpdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
ntpd-rs does not validate the length of NTS cookies in received NTP packets to the server. An attacker can crash the server by sending a specially crafted NTP packet containing a cookie shorter than what the server expects. The server also crashes when it is not configured to handle NTS packets.
ntpd-rs running purely as an ntp client is not affected.
Patches
The issue was caused by improper slice indexing. The indexing operations were replaced by safer alternatives that do not crash the ntpd-rs server process but instead properly handle the error condition. A patch was released in version 0.3.3
Workarounds
ntpd-rs running purely as an ntp client is not affected. By default, ntpd-rs packages are not configured to run as a server.
For machines where serving the time is required, there is no known workaround. Users are recommended to upgrade ntpd-rs as soon as possible.
References
https://github.com/pendulum-project/ntpd-rs/pull/752
We would like to thank @mlichvar for identifying this issue
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | ntpd | ≥ 0.3.0&&< 0.3.3 | 0.3.3cargo update -p ntpd --precise 0.3.3 |
Affected Products
ntpd-rstweedegolfDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ntpd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ntpd to 0.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-33192 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-33192 in your dependencies?
Find it across crates.io, including transitive dependencies.